Warning: Memcache::get() [memcache.get]: No servers added to memcache connection in /home/measured/public_html/libs/phpcache/drivers/phpcache.driver.memcached.class.php on line 75

Warning: Memcache::get() [memcache.get]: No servers added to memcache connection in /home/measured/public_html/libs/phpcache/drivers/phpcache.driver.memcached.class.php on line 71

Warning: Memcache::add() [memcache.add]: No servers added to memcache connection in /home/measured/public_html/libs/phpcache/drivers/phpcache.driver.memcached.class.php on line 65
General Electric Complaint - Hydrowave washer - GE hydrowave
General Electric Complaint

General Electric Complaint

ADVERTISEMENT

Hydrowave washer - GE hydrowave


I bought a Hydrowave less than 18 months ago, yesterday it stopped working and today I bought a new washer!
I have never liked the hydrowave, never got clothes clean and they were wadded up in the bottom of the machine, wrinkled and wrapped up.
GE has quite a game going as this washer was expensive!! Desided that when it stopped I would not repair it but who would have guessed it would have died so soon.
My NEW WASHER is NOT a GE and as the hydrowave was my first GE, I will probably never have another! Junk!!!


Share This Review:



         


Is this your Business? Claim Your Business Free and reply to this customer

CONTACT THIS BUSINESS

Post a reply for this review COMMENT
WRITE to General Electric
SUBMIT a ticket
for General Electric
WATCH videos
for General Electric
More General Electric Reviews and Complaints MORE reviews and complaints
for General Electric

BUSINESSES REPLY HERE

Company was claimed GREAT NEWS, this company has Partnered with MeasuredUp and uses it to answer you!
Link to MeasuredUp BUSINESSES: Free Customer Service Excellence Badge
Take the pledge BUSINESSES: Free Customer Service Pledge Badge
Upgrade Account BUSINESSES: Build your customer service online reputation


ADVERTISEMENT


Comments


Talia25 says: (3 years ago)
 0
I just had one delivered and it is awful! The squealing is horrendous. I am going to call them and tell them to pick it back up!



theohbrown says: (7 years ago)
 0
I'VE BEEN RIPPED OFF! Wow, I thought it was just me! I have had the GE hydrowasher for less than two years, and now it doesn't work. I tried the troubleshooting tips under the "operation" section, and it still does not work. I reset my electric breaker; I removed the plug from the outlet for 2 or more minutes; I checked the machine magnet (it is still in place); I reviewed the GE website for FAQs. Nothing is working. I feel like I've been ripped off as this was a very expensive washing machine, and I did not think that I would have to have it serviced so soon after my purchase. I use the washer every 7-10 days! I went with the GE brand because I've had success in the past (my last Ge washing machine lasted 14 years)! The GE hydrowave is crappy engineering! I WANT A REFUND!




login with Facebook and share your reviews

More General Electric reviews


More

Similar reviews


More

[Top]

Bookmark/Share this page

This page is under construction.
It will be up and running soon with new features to make you smile more.
Thanks,
The MeasuredUp Team